The YM_MINI usb controllable synthesizer kit

Description

The YM_MINI uses a virtual midi driver and a built-in Arduino circuit to fully control a real YM2149 chip in stereo.

The chip is most well known for its use in the Apple II Mockingbird soundcards and Atari ST computers. The YM or the chip from which it was derived (GI’s AY-3-8910) also created the music and audio in the Intellivision, Vectrex, some MSX systems, Sinclair ZX and Spectrum home computers, and many arcade machines.

The synth can be played via a live controller like monome or Oxygen8, or any midi-capable software such as Logic-Pro, Energy-XT, FL_Studio, Reaktor, Reaper, Max/MSP, PureData, Renoise, — pretty much anything that can sequence midi!

Documentation

Build Instructions for the YM_MIDI PCB kit

Instructions for driver, Software and MIDI control of the YM_MIDI

Upgrading the YM_MINI Firmware

The Arduino software for Windows, Mac, and Linux can be found at the : Arduno.cc Download Page For those familiar with the Arduino platform, the YM_MINI appears as an “Arduino Duemilanove w/ Atmega328” on the serial port used by your FTDI USB/Serial cable. For those not familiar, here is a step by step guide:

  • 1. Download YM2149_VR1.ino (link is below) to any folder.
  • 2. Rename that folder to “YM2149_VR1” (nothing else)
  • 3. Install the Ardunio software as per the instructions on Arduino.cc for your operating system. – The drivers have already been installed, when setting up your YM_MINI.
  • 4. Plug in your YM_MINI cable to your computer and the YM_MINI. DO NOT open “Hairless MIDI” or any serial-midi software.
  • 5. Open The Arduino environment (software), click on File > Open
  • 6. In the “Open an Arduino Sketch” window, navigate to your “YM2149_VR1” folder and select the file “YM2149_VR1.ino”
  • 7. You should now see an Arduino window with gray text saying “YM2149 Simple Hardware Driver…” and the entire programming code for the firmware.
  • 8. In the menu, select Tools > Board > Arduino Duemilanove w/ Atmega328
  • 9. In the menu, select Tools > Serial Port > (the serial port you normally select in Hairless Midi)
  • 10. Press the small red “reset” button on the oneString (you'll have 3 seconds to do step 11 once this is pushed.)
  • 11. Below “File” in the menu, there is a check-mark and an arrow pointing to the right. Click the arrow pointing to the right (called “Upload”).
  • 12. Wait…

If everything worked, you should see some messages pass in the blue bar of the Arduino software: Compiling Sketch (with a progress bar) Uploading… (and then ) Done uploading. If you received an error: “Serial Port (…) already in use”, verify that Hairless Midi or your Serial-Midi program is closed. If you receive an error mentioning “avrdude” or any other error, verify that the oneString is properly connected, and that you pushed the oneString's reset button immediately before clicking the upload button in Arduino software. (Trying again will hurt nothing!)

Then cycle the power and test as per the instructions pdf above.

Source Documentation

Version R1 Source Code: Zip file includes the Arduino source code and schematic released under GPL V3.0, 27-Feb,2014

KIT_MIDI_V2_WIN: an open source Java based midi-toserial bridge driver for Windows machines

Legacy OSX version: broken on the latest LION; use Hairless MIDI below

FTDI Drivers for all Operating Systems

Hairless Midi bridge: The awesome project by Angus Gratton -This is currently the best recommendation for a midi-to-serial bridge on OSX